Teams Management Availability
Incident Report for Living Security Platform
Resolved
This incident has been resolved.
Posted Aug 26, 2022 - 19:16 UTC
Investigating
We are currently investigating an availability issue with the Teams - Management application. Gameplay should not be affected
Posted Aug 26, 2022 - 18:59 UTC
This incident affected: Teams - Management.