3rd Party Outage Impacting Cyberescape Online & Phishing

Incident Report for Living Security Platform

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 21:24 UTC

Monitoring

We are monitoring our application's health and everything appears operational
Posted Jun 12, 2025 - 19:30 UTC

Identified

A widespread 3rd-party outage is impacting portions of our infrastructure hosting
Posted Jun 12, 2025 - 18:55 UTC
This incident affected: Teams Gameplay and Phishing Training.