Instant Campaign Launch Latency
Incident Report for Living Security Training
Resolved
Amazon Web Services has resolved their latency issues. Campaigns should now be operating normally.
Posted Aug 18, 2021 - 13:01 UTC
Identified
We have been notified of elevated latency issues within our cloud provider Amazon Web Services. This is currently impacting instant launch of campaigns. We are monitoring the situation.
Posted Aug 17, 2021 - 20:16 UTC