3rd Party Outage
Incident Report for Living Security Platform
Resolved
This incident has been resolved.
Posted Feb 22, 2024 - 01:31 UTC
Investigating
We are currently monitoring an issue with a third-party authentication provider which is causing latency and preventing some features from being available.
Posted Feb 21, 2024 - 23:45 UTC
This incident affected: Campaign Management.