Phishing Availability

Incident Report for Living Security Platform

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 16:26 UTC

Update

We are continuing to investigate this issue.
Posted Jun 19, 2025 - 16:26 UTC

Update

We are continuing to investigate this issue.
Posted Jun 19, 2025 - 16:22 UTC

Investigating

We currently are observing and investigating high error rates in our Phishing product which is impacting availability
Posted Jun 19, 2025 - 16:22 UTC
This incident affected: Phishing Training.