SMTP Delivery Degraded
Incident Report for Living Security Training
Resolved
This incident has been resolved.
Posted Feb 17, 2021 - 00:39 UTC
Identified
Our SMTP provider is currently experiencing an outage which may effect the delivery of email notifications from our system.
Posted Feb 17, 2021 - 00:08 UTC