Phishing Connection Issue
Incident Report for Living Security Platform
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 20:47 UTC
Investigating
We are currently investigating an issue with connectivity to our Phishing platform.
Posted Mar 05, 2024 - 17:23 UTC